Results 1 to 2 of 2

Thread: New Guy Here, 2/50/2 user greetings and salutations

  1. #1
    Join Date
    Dec 2013
    Location
    Palm Desert, CA
    Posts
    1
    Rep Power
    0

    Default New Guy Here, 2/50/2 user greetings and salutations

    Hi Fryette Forum,
    I come in peace.

    Purchased a VHT 2/50/2 some 6-8 months ago. It was on eBay. I paired it with my Peavey Rockmaster Preamp and Avatar 2X12 cab with Celestions. Was in tone heaven.

    I noticed that the power amp got really hot. Like, can't even touch the top panel hot. I was running it in class A, stereo. I wound up taking off the top panel and running it that way, since it seemed to vent better. It sits in the bottom of the rack and has an empty rack space above it.

    After several months of use, the left side started introducing a high pitched squeek to the sound. So, I'm down to just using the right side.

    Basically, I'd like to know what I'm doing wrong and how to go about correcting it. Getting this power amp back to full operation is a top priority with me. Thanks for any useful info., and cheers!

  2. #2
    Join Date
    Feb 2008
    Location
    San Jose, California, United States
    Posts
    1,217
    Rep Power
    10

    Default

    Welcome!

    The power amps will run hot. My guess on the screeching noise is that a tube has gone bad.
    Ultralead
    D120H
    Sig X
    Fat Bottom 4x12
    D412
    Valvulator I

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •