Search:

Type: Posts; User: TWILT

Search: Search took 0.01 seconds.

  1. Well, I had to take the Sig to a local shop. ...

    Well,
    I had to take the Sig to a local shop. Could be a few weeks before I hear anything due to the back log at the shop.

    Before I took it to the local shop, I had tried, REPEATEDLY, to...
  2. Yepper. I have replaced all of the tubes. Still...

    Yepper. I have replaced all of the tubes. Still no improvement.


    ~Troy
  3. Yep. I've noodled with every switch and knob to...

    Yep. I've noodled with every switch and knob to see if I could isolate the issue....to no avail.

    I'm at a loss. I love this F'n amp. It's my No.1:sad:

    As soon as I hear back from Fryette,...
  4. ***Update*** I replaced the power tubes....no...

    ***Update***

    I replaced the power tubes....no change. Same harsh grainy, gainy fuzz.

    So I started noodling with the volumes on the Lead and Rhythm channels and noticed this:

    When i dime...
  5. Ok..so i replaced all the preamp tubes, including...

    Ok..so i replaced all the preamp tubes, including th PI with new ones. And still no improvement.

    Sooo...could failing power tubes do this? Like i said, the tubes are a few years old, but i've...
  6. My Siggy just got VERY gainy, grainy and fizzy! Thoughts?

    Fired it up yesterday, and the lead and rhythm channels are suddenly VERY gainy.
    The clean channel is unaffected.

    I've eliminated everything in the signal chain by plugging straight in with...
Results 1 to 6 of 6